Slackware 12.0


New Member
Hallo, I have tried 'picaxe08m' on a slackware 12.0 system and a Asus EEPC 4G.

The Asus EEPC worked 100% no problems !!

I could run it with the -s option and it reported success. I had two problems: libpcre and lines ending with CRLF. The PCRE problem was easy to fix. For the CRLF I had to push the .bas through a dos2unix program and then it worked.

My problem is that it reports an error "Hardware not found". I did the modprobe command to load the driver and also the udev rules.d file (as specified in the PDF doc). The cable is fine since I used it both from a Windows environment and the Asus EEPC (see above).
Correction: If I run the program twice directly one another, the 1st one fails and the second one works. If the time between each run is more than a second or so, it fails always.

Slackware does report the USB as a AXE027 cable. I can supply the output of lsusb -v -d 0403:bd90 if it helps.

Is there anything else I can look at/for to make this work ?

Great that Linux is supported, which the 14M/20M is also part of the package in the future?



Technical Support
Staff member
If your slackware machine has a traditional serial port it would be very useful to try that with a serial cable instead. That would confirm the issue is with the USB driver rather than the compiler, as there are two possibilities here.


Technical Support
Staff member
We are beta testing 08M and 18X only. However all current parts will be part of the full release.