DS1307 (RTC) on DataLogger AXE110P - No flash 1Hz!

zorgloub

Member
Good evening to all,

I'm currently testing the Datalogger (AXE110) with the DS1307 real-time clock for this module.
After setting the RTC time with the appropriate program, created by the wizard, the green LED supposed to flash every 1sec ... does not work!
Have you tried this Datalogger with the DS1307 and encountered this problem?
Have you solved it ??

To read you.

thank you
 

hippy

Senior Member
I believe a similar occurrence was reported elsewhere, and that turned out to be using a version of the generated mission for a different chip to which was being used. But it might be something else.
 

zorgloub

Member
Hi, Hippy
Thanks for your intervention.
But, it does not seem to me that there is a problem in the program of the "Mission" but only a problem of programming of the setup of the DS1307.
The fact that this flash does not work makes me think that the DS1307 does not program.
I tried with various DS1307 and the results are identical.

Below the code used:

---------------------------------
CODE
---------------------------------
' AXE110 PICAXE – RTC Setup
' Automatically generated by Picaxe Editor 6.0.9.2 DS1307 Wizard

#Picaxe 18M2

symbol secs = b0
symbol mins = b1
symbol hour = b2
symbol dow = b3 : symbol chkdow = b9
symbol day = b4 : symbol chkday = b10
symbol month = b5 : symbol chkmonth = b11
symbol year = b6 : symbol chkyear = b12
symbol century = b7
symbol control = b8 : symbol chkctrl = b13

high 5 ' write protect eeprom

' hi2csetup i2cmaster, %01101000, i2cslow, i2cbyte '$68 is the Non-configurable slave adress of a DS1307
hi2csetup i2cmaster, %11010000, i2cslow, i2cbyte '$D0 is the adress generated by the Wizard !?
' Note that I do not get the flash 1HZ either with one or with the other address !!!

century = $20
year = $17
month = $02
day = $04
dow = $07
hour = $11
mins = $30
secs = $49
control = $10 '$10 = Flash, $00 = No Flash

hi2cout 0, (secs, mins, hour, dow, day, month, year, control)
pause 50

hi2cin 3, (chkdow, chkday, chkmonth, chkyear)
if chkdow <> dow then fail
if chkday <> day then fail
if chkmonth <> month then fail
if chkyear <> year then fail

ok:
high 3
sertxd("Time set okay",cr,lf) ' For console debug
pause 1000
goto ok

fail:
high 2
sertxd("Time setting failed",cr,lf) ' For console debug
pause 1000
goto fail
 

Attachments

hippy

Senior Member
When that program is downloaded, does it show "Time set okay" or "Time setting failed" ?

That program seems to only set the green led if the time is successfully, red if it fails; is the green or red LED on ?

There does seem to be a bug in the Wizard generated RTC setting code, as pin 2 and 3 control a single bi-directional LED but only one side of the LED is ever set when using an 18M2.

It looks like the RTC setting code may not have been upgraded to support the 18M2 now fitted to the datalogger modules and is still for the earlier 18X. We would need to investigate further.

Adding LOW 2 and LOW 3 at the start of the program may help illuminate the LED.
 
Last edited:

zorgloub

Member
Thank you for your intervention.
It does seem that the Wizard program is not up to date.

Moreover, I have just noted, that on this kit that I just received assembled by Picaxe, the green led is welded backwards!
Unbelievable !!!!
I will check the other 4 kits that I received at the same time!
 

JPB33

Senior Member
Yes it was me that had the same problem with the LED round the wrong way as received, turned round and flashes fine, Hippy has a good memory as it was posted/reported 26-11-16.

My big blunder though was not selecting the 18m2 at the beginning of the setup and sorted by Hippy, many thanks!
 

hippy

Senior Member
I cannot find the post but can recall it. If the direct to RTC LED is inserted backwards then we onbviously apologise for that, will have to investigate how and why that occurred and will seek to resolve it.

I guess that is LED1, the one closest to the coin cell battery holder. I don't have a datalogger board to hand but from the silk-screening shown in the manual that looks like it should be correct.

@JPB33 : With your board now working; is the flat on the LED towards the RTC or away from it ?
 

JPB33

Senior Member
On mine the flat on the LED is now towards the RTC same as the silkscreen so I suppose an easy visual check is to see that the flat lines up with the silkscreen image. I never noticed this initially but discovered there was 0v on pin 7(?) of the RTC, reversed the LED and bingo!
 

stevesmythe

Senior Member
I bought a datalogger in the Picaxe sale before Xmas and my green LED was soldered backwards too. However, I made a hash of unsoldering it and damaged one of the solder pads so I couldn't solder it back in place. Now I have a new datalogger with a hole where there should be a green LED.
 

zorgloub

Member
This is really a crazy bug this datalogger kit! :confused:
I thought Picaxe was a little more careful!
In addition, the Reset button has no effect since the 18M2 has no pin reset!
I also notice that once the "mission" is over, the program has to be reloaded.
I do not understand why switching off the power (hard reset) does not restart the program at the beginning !??
An idea ?
I think it would be necessary to erase the EEPROM which records the data at the beginning of the program!
To test ...
 

Technical

Technical Support
Staff member
Just to note to apologise that our assembly sub-contractor did make some boards with the green LED around the wrong way in one batch of boards in 2016, despite having made the same board for over 13 years...

All shelf stock have now been corrected.
 

JPB33

Senior Member
Thanks for the update, I certainly learned quite a bit sorting mine out! My chief regret is I paid full price!
 

DenisOConnell

New Member
I couldn't get the clock to set on my Axe 110. Everything else would work on board.
I got new RTC chip and battery but no go.
In the end I changed from a 3xAA to 4xAA power supply (Alkaline) and no problems despite the data sheet saying
"The datalogger is designed to run from a 3xAA battery pack (3 x 1.5V = 4.5V with alkaline cells). If using rechargeable cells a 4xAA pack should be used to (4 x 1.2V = 4.8V). "

My guess is the RTC chip needs a full 4.5V or more to work.

I tried to enter the slave address from RTC datasheet (as per zorgloub) but compiler picked it as wrong, must be an eight bit address with LSB being zero.

' hi2csetup i2cmaster, %01101000, i2cslow, i2cbyte '$68 is the Non-configurable slave adress of a DS1307
hi2csetup i2cmaster, %11010000, i2cslow, i2cbyte '$D0 is the adress generated by the Wizard !?
' Note that I do not get the flash 1HZ either with one or with the other address !!!
 

Aureli

Member
I bought a data logger last May'2020 and found the led1 on DS1307 backwards. Be careful and check this Led and electronic board.
Fortunately, I read in the forum that sometime passed this issue and checked this led, now it's working.
Best regard
 
Top