Difference between a servo controller and servo driver ?


New Member
Hello, this is my first post here.

2 days ago I started working on my picaxe experimenter pack. I soldered the thing and it worked immediately. I want to build robots. I hooked up a simple servo to my board with a PICAXE 18X on it and used the SERVO command like this:
main: servo 4,75 	‘ move servo to one end
	pause 2000 	‘ wait 2 seconds
	servo 4,150 ‘ move servo to centre
	pause 2000 	‘ wait 2 seconds
	servo 4,225 ‘ move servo to other end
	pause 2000 	‘ wait 2 seconds
	goto main 	‘ loop back to start
The servo worked. But it only waggled back and forth maybe 15 degrees. I have little electronics and BASIC experience and have now decided to buy a servo driving device from the webshop.

I want to control more than one servo more than 15 degrees accurately at a time. I am ordering the microbot as well as some other interressting stuff. Its a big order in the range of 280 E (live in the Netherlands). Finally I want to be able to make my own circuits and boards and robots to my own liking in as short a time as possible.

What is best to use to control the movement of BEAM like robots? Servos, motors or stepper motors?
Whats the difference of a servo driver and a servo controller?

Sorry for nonsense making comments if they are present in this post and thanx for possible feedback.
Last edited:


That's odd. With the values you've used it should move +/- 45 degrees.
It might be a function the particular servos you have.
Check that they are OK to move further mechanically, ie they don't hit an end-stop and then just change the values to make them move further.

An 18X can control 8 servos at the same time.
I suggest you have a look at a few BEAM robotic sites to get an idea for how other people do these robots. Servos are BIG when compared to BEAM and are not used in the true BEAM arena. For BEAM you are talking more along the lines of pager vibro motors and the like. Even things like piezo sounders are used to effect motion.


New Member
Programming or Hardware???

Maybe the problem is not program related...
try putting a 220uf (or similar) electrolytic capacitor across the power supply, this should fix the problem.