AX027 errors

#1
Hi all

Just update to latest Program Editor V6.0.9.2 and now on my main PC I cannot download to a number of working circuits, it get 'cannot find hardware error' immediately I click download. My laptop has same update and is working fine with my working circuits.

Have tried different combinations of cables (x6), com port numbers etc, re installed drivers but to no avail - any thoughts or solutions to this issue?

Cheers

BPS
 
#3
Have tried that and makes no difference, the port is seen but won't find the hardware, which works with my laptop and same cable but not on my desktop, it's very odd:(
 
#4
Further details can get it to work once and then it stops working, when programming the compiler errors once it tries to write to the virtual com port, it looks like the port is dropping out, have to restart the program to get a single shot at downloading - not very productive!! Any thoughts from Technical Support?
 
#5
What operating system are you using?

I have found that with windows 10Pro (64-bit) on my desktop that even though the AXE027 cable is shown on COM 3 or 4 when plugged it at the front of my main desktop, that I must select the alternative of the two mentioned ports for a download to work.

Keep in mind that if the AXE027 cable is not already plugged in to last used port when the PE is started, that it defaults to COM 1 until you scan and select the correct port.
 
#6
Have just run 3 courses for teachers, on laptops Win10 & Win 7 and on PC's Win10, I'm finding that after a couple of downloads, downloading starts to fail with hardware not found on COM port. Have used the test rountines cable ok, used target board on other systems and downloads ok.

Looking like some strange software issue around the virtual COM port and/or USB driver (unlike since it is the FTDI one, which is solid), beginning to suspect a .NET issue.

Been using PICAXE for 15yrs plus with no issues until the last couple of months, is it time add the ability to go via the USB driver direct and miss out the virtual COM ie not use the CDC route?!
 
#8
Have tried hard reset with no effect same issue, still looking like a software issue - no amount of driver reinstall is making any difference, had two more schools contact me with similar issues - not very happy. I think a phone call might be in order to see if wecan bottom oput this issue.
 
Top