40x2 giving headaches

sbscott

Senior Member
#1
Ordered and received two new 40x2 for a backup chip for my home security system. Got out the bread boarding box and hooked up the power leads (pins 11/12 & 31/32) +5 and Gnd respectively and put a 4.7k res on pin 1. Then connected the AXE027 cable.
Flipped the swt, hit the program button and.. NADA. The computer could not find anything hooked up the Com4/AXE027.
Replaced the 40x2 with an 08m2, 14m2, 28m2 and a 28x1. All worked just fine.
Current draw with the 40x2 was about 4 millamps. Tried the other one, same results.

I must be missing something. Hard to believe Anderson sent me a couple of bad chips...

Any thoughts?
 

hippy

Technical Support
Staff member
#2
Should have worked just as well with the 40X2 as it did with the others. Initial thoughts are a possible miswiring somewhere, perhaps Serial In and Serial Out crossed over, having accidentally connected the reset pull-up to 0V or using something not actually 4K7.

Was it a "Hardware not found" error or something else ? What does a Check Firmware say ? Did you try a Hard Reset ?

Might be worth posting a picture of your breadboard setup.
 

sbscott

Senior Member
#3
I have received two additional 40x2 chips from Eric (very impressed with his response to my problem!)
Unfortunately, I am seeing the same 'can't connect' error. I have posted a Youtube that shows a still of a 08m2 and a video of its test, then a pic then video of the 40x2 test.
Seems straightforward but, the 08m2 test fine but NADA on the 40x2
The Youtube is at https://youtu.be/fvchWJRz0KY
 

premelec

Senior Member
#4
I can't really make out your programming connections - seems likely you have some wiring error somewhere... When I run into situations like this I pull it ALL apart and check everything and re-wire - sometime that works... you need the reset pin wired correctly as well as the power and programming pins...
 

marks

Senior Member
#5
Hi sbscott,
all those extra pins cause leakage and noise just improving supply will help.
microchip minimum design uses a 10uf and 0.1uf close to the supply pins of the chip.
for a 40x2 most people would use a 22uf 0.1uf and 0.1uf
any supply to a device more than 6 inches from its source needs its own decoupling
 

techElder

Well-known member
#6
Current draw with the 40x2 was about 4 millamps.
Current draw of 4 mils at idle seems high with nothing connected.

Power positive is legs 32 and 11; red wires on your board.

Reset is leg 1 through a resistor to positive (red wire). Your reset connection is hard to see in the video, but could be going to power negative. Reset must be tied to power positive, or the 40X2 is just as good as a brick.

Forget YouTube and post the photos here of your connections, so we can see where your wires go without ambiguity. Will be much easier to help that way.
 

sbscott

Senior Member
#7
This is very frustrating! I have been working with the PICAXE for years and this is getting my goat!
See the pics. With my scope, I see a trigger coming from the computer on the RX in (pin 6) but nothing out on pin 7.
IMG_0644.jpg IMG_0645.jpg
 

premelec

Senior Member
#8
I'm not seeing ANY bypass capacitors NEAR the power pins. Have you checked the actual voltage at the RESET pin?

I add that there is capacitance between adjacent locations in the breadboard... sometimes this is a problem... have you worked with 40 pin PICAXES before on this type of setup?
 
Last edited:

hippy

Technical Support
Staff member
#11
Reservoir and decoupling caps are not always essential and it should not be a problem to leave all I/O floating.

It would be worth putting a couple of 100nF on the vertical power rails to see if that works. And maybe change the 10K reset resistor to 4K7 but I doubt either will affect anything though would be pleased to proved wrong.

It would also be worth checking all the voltages at all the points power goes to, and also worth doing a continuity check of all 0V tracking.

Checking what the markings are on the PICAXE itself would be a good idea. I am wondering if it could be an older 40X which requires a resonator to run rather than the 40X2 you think it is ?
 

sbscott

Senior Member
#12
Yes, I have worked with the 40x1. In fact, my home alarm monitoring system has been running none stop since 2013!
As I have mentioned before, using the same breadboard, I set up 08m2, 14m2, 28x2 after I was unable to get the 40x2 up and working. All programmed with no problems. The 40x2 are all brand new from Anderson.
 

sbscott

Senior Member
#14
Sometimes things get figured out!
Looks like I have an intermittent problem with the way I set up the AXE027 programming cable which I found. Just before I was going to throw out six 40x1&2s, I tried my old RS232 programming cable. I had gone with the AXE027 because I had had problems with the old setup. Well, the 40x1&2s programmed with NO PROBLEM! I am a happy camper!

The moral to this story for those folks out there who are having weird and/or unexplained problems....CHECK YOUR SETUP! Be sure it is what it is.

A lesson learned...again!

Thanks for everyone's help and insights, as usual.
 

hippy

Technical Support
Staff member
#16
Looks like I have an intermittent problem with the way I set up the AXE027 programming cable which I found.
Glad to hear you have found the problem. It seemed it either was the PICAXE chips or something with your setup. Unlikely to be the PICAXE and your setup seemed to be working so it was very hard to see where the problem actually was.

I dismissed it being a cable or connection issue when you had it working with other PICAXE chips and you could see the test voltage reaching the 40X2's input.

I was tending towards 'send it back, to get the chip tested'. That would have confirmed that it wasn't the chip but not sure it would have greatly helped with solving what the problem was though.
 
Top