Windows 10 verses AXE027 failed

#1
My old Vista computer died (PS failure) so I was forced into windows 10 with the new computer.
I can't get my AXE027 driver down load to work.

Here is what I tried several times, both preinstaler and the other installer.

Windows 10
installed driver axe027
running picaxe editor 5.xx shows no serial ports available
used device manager to remove axe027 driver (it said not available but removed it)
reinstalled axe027 driver, still shows no serial port available in picaxe editor
.
EDIT:
When plugging in the AXE027 I do get the tone that the windows says something was pluged in.
.
My project is dead until I get the download AXE027 working again.
HELP
.
Paul
 

hippy

Technical Support
Staff member
#2
When you plug in the AXE027 cable and get the plugged-in tone, when you go into Device Manager, what do you see there; any sign of the AXE027 or anything with exclamation marks alongside them ?

Rather than removing any AXE027 devices, try manually updating the drivers from the directory you have extracted them to on disk. You usually have to do this twice, because there are drivers for the USB cable, and drivers to make the USB device appear as a Serial Port (COM).
 
#3
When I plug in I get the tone, then when I go to device mgr it says:
AXE027 PICAXE USB
Driver is unavailable
Tried reinstalling a couple of times, but same results.
Confused, should this install be done without the AXE027 plugged into to the USB ?
& without the other end plugged into the 08m2 board ?
 
#6
Really appreciate you trying to get me to get this driver installed.
This is a windows 10, so while the instructions are similar, not quite the same as windows 7.
After I cleaned old zip files and "USB Driver not available) from the drivers page, I followed the instructions, but ended up with the drivers page saying "AXE07" driver not available, same as before.
I also shutdown and restarted the computer, but still says AXE027 driver not available.

So it looks like something related to AXE027 got loaded because before I down loaded and unzipped the drivers page did not show anything about AXE027, but did show the msg AXE027 driver not available.
I have tried it with the axe cable plugged in and without the cable plugged in (to the same port each time) I get the tone that the computer recognized something is plugged in.
I must be doing something wrong, or win 10 is messing with the driver ?
God, for the old days of DOS. :rolleyes:
 

hippy

Technical Support
Staff member
#7
What exactly is showing "AXE027 driver not available" ?

At what stage in the instructions do things start to go wrong or diverge from what is expected to happen ?

To manually install the drivers the AXE027 has to be connected to the PC.

What does Device Manager show with the AXE027 cable plugged in ?
 
#8
I will printout the instructions and note what happens at each step.
Here is a screen shot of the msg about driver not being available.
screensht01.jpg
I will get back after I do the above.
Many thanks for you patience.
Paul
EDIT: This was done with the AXE027 plugged into port but not plugged in to a development board.
 
#9
Well, I finally got it to install correctly by trying different methods. Not sure I could repeat this but I will try to document for any other windows 10 users.
Many thanks Hippy for you support.
Paul
 
Top