Verification error - MacAxePad 1.4.1

#1
We built a PicAxe 08 starter board. When we attempted to program it using MacAxePad 1.4.1, we got one of two verification errors when clearing memory or programming the first example program from the Getting Started Giude: either "sent 0x00 and received 0xffffff" or "sent 0x00 and received nothing" depending on the cable. Repeated the same process with the same hardware on a PC running PicAxe Programming Editor 5.5.0, and had no problem. We also tried programming a known good Picaxe 08 starter board that I had programmed successfully several months ago using the same cable and Mac - same error. Is there a bug in this version of MaxAxePad?

Using either batteries or a 5VDC regulated supply. Voltages check out.
Using Picaxe 08M2, MacAxePad 1.4.1, Mac OS 10.7.5
Loopback test works
Correctly reads back firmware version
Terminal shows "this is your PicAxe08M2+" repeatedly
Clear Hardware Memory gives a verification error
Program gives the same verification error

Repeat: our hardware and power supply all check out. We are able to program on a PC, but not with MacAxePad on Mac.
Help!
 

Technical

Technical Support
Staff member
#2
MacAXEpad should work fine. Is it an AXE027 cable you are using?

Verification errors are almost always battery related - try with 3 new AA cells.
 
#3
Did you read the whole post? As I explained, this is not a battery related problem, and I tested the cable several different ways and used more than one cable. All arrangements work on the PC. None work on Mac with MacAxePad 1.4 or 1.5. We have no problem with hardware, power supply, or cable so long as we program the device on a PC. We have a serial cable and a sparkfun picaxe programming cable, as the AXE027 was not in stock.
 

tmfkam

Senior Member
#4
MacAXEpad is definitely working for me. Just downloaded a 1398 byte (?) program to check.

08M2+
MacAXEPpad V1.5.0,
OS X Yosemite.

Then again, I am using an AXE027.
 
#5
I'm getting the same error message using an AXE027 cable and fresh batteries with a PICAXE18X on a Windows 7 laptop. It's checked cable and chip as correct and working and it's happily programmed a PICAXE08M. I'll try alternative approaches, but I would be grateful for any help.
... and, just in case you think "It's an 18-pin chip so the power supply pins are different from the 08", I have connected the power supply correctly to each chip.
 
Top