Serin 18m2

tim griff

Dear All,
Help please,

I have an RF solutions GPS modules connected to a 28X1, all worked well on an old project using

serin 1,T4800,("$GPRMC,"),b0,b0,b0,b0,b0,b0,b0,b0,b0,b0, b12,b0,b0,b0,b0,b0,b0,b0,b0,b0,b0,b0,b0,b0,b0,b0,b0,b0,b0,b0,b0,b0,b0,b0,b0,b0,b0, b1,b2,b3,b4,b5,b6,b7,b8,b9,b10,b11

I just recovered the gps module to put on a new project using an 18M2 but, using the same code the variable do not populate at all(using debug).

I changed serin 1 to serinl c.1 ..... no good

I added high c.1 ( in the start up section)............. no good

I changed to a different nmea code ..serin 1,T4800,("$GPGGA,") .... no good

I then removed the qualifier ($GPRMC) and can see the variables being populated. Even if the module has not "locked on" data(although not valid) should be sent out using one of five nmea codes.

any thought, and happy new year



Senior Member
Your complete code would be most helpful.

With the 18M2 you will get better serin performance if you increase the clock speed to 16 Mhz

setfreq M16

serin B.1,[B][COLOR="#0000FF"]T4800_16[/COLOR][/B],("$GPRMC,"),b0,b0,b0,b0,b0,b0,b0,b0,b0,b0, b12,b0,b0,b0,b0,b0,b0,b0,b0,b0,b0,b0,b0,b0,b0,b0,b 0,b0,b0,b0,b0,b0,b0,b0,b0,b0,b0, b1,b2,b3,b4,b5,b6,b7,b8,b9,b10,b11
You could also use M8 and T4800_8, however the default 4Mhz with a baud rate of 4800 may not be fast enough for so many back-to-back bytes.

tim griff

Hi Thanks for the prompt response. the project is a four digit 7 segment display using electromechanical vane displays .

2 18m2's with darlingtons will drive the simple set/reset relays. the complete gps code was

pause 2000
goto main

all the b0's are to "loose" data I do not want and only populate variables with useful data. The above line has worked for years on a tracker for my motorcycle getting eastings and northings data. In the new project I only want utc time and date

I see your sample codes uses B.1.... is there a problem using C.1 as I'm using all the b pins( lets pinB = etc)

I'll try your suggestions later ..... thanks Tim

tim griff


I tried this and still the same . since then I changed the GPS unit and played around with calibrate freq, but to no avail,

It now works since I changed the 18M2. I'm not sure it was this as I also moved a 12v line away from the GPS modue---noise?