Serial output window auto cr,lf

cravenhaven

Senior Member
When I use SERTXD to send output to the screen 1 character at a time the PE seems to put a CR,LF after each character. When I run the program on the picaxe chip it works correctly.
Also, is there any way to turn off the baud rate messages that constantly show when in simulation mode. (picture attached)
I have a series of messages stored in EEPROM that I want to display when required.
my code is as follows:
EEPROM 1, ("DS1994 NOT found")
.
.
.
Display_Error:
SERTXD(CR,LF,"errormessage : ")
FOR index=1 to msglength
READ errormsgno,message
SERTXD(message)
INC errormsgno
NEXT

but the display I get prints out "errormessage" ok, but the EEPROM part of the message comes out in a vertical manner interspersed with baudrate etc messages.
Thanks
Allan
 

Attachments

hippy

Senior Member
Use view -> Options -> Simulation and untick the Display Baud Rate Information messages option.
 
Top