Runtime error 339 - srcvw4.dll

Grogster

Senior Member
Runtime error 339 - srcvw4.dll [SOLVED]

[please see the end of this thread for correct method to solve this issue]


Trying to install the latest programming editor for the 18M2 support, and am getting runtime error 339 saying that srcvw4.dll is not installed or registered. The file is there in C:\WINDOWS\SYSTEM32

System is Windows XP Pro SP3.

DLL file details are:

SourceView ActiveX 4 Control Module
Version 4.0.1.2

It is 430,080 bytes in size(420kb)

The previous version of PE worked fine - am I missing some additional DLL's or 3rd party applications or something?

As per the instructions in bold at the download page, I uninstalled the old version of PE BEFORE I installed this new one. The install completed fine, I get this message when I try to start PE.
 
Last edited by a moderator:

hippy

Senior Member
Srcvw4 Errors

You should have received the error message attached.

You may need to remove \Windows\System32\Srcvw4.dll manually. That will normally be on C: but may be on another drive as in my case.
 

Attachments

Last edited:

Grogster

Senior Member
Okey dokey - will try that now...

EDIT: Does not work, at least, not for me.

Proceedure:

- Uninstall PE
- Delete Srcvw4.dll from c:\system\system32
- Reinstall PE
- Exact same error.

Upon reinstallation, Srcvw4.dll has been added to c:\system\system32

I don't get that error message you attached, I get another one.
All it says is:

Run-time error 339

Component 'srcvw4.dll' or one of it's dependencies not correctly registered: a file is missing or invalid.
 
Last edited:

Technical

Technical Support
Staff member
Very peculiar Windows being installed in a folder called 'system'?....

Anyway if that is correct, your file is not registered correctly so:

Click Start>Run
then type

regsvr32 "c:\system\system32\Scrvw4.dll"

For other reading this thread it would normally be
regsvr32 "c:\Windows\system32\Scrvw4.dll"
 

Grogster

Senior Member
System is in c:\windows\system32 - I put one two many system's in the tree! :(

For other reading this thread it would normally be
regsvr32 "c:\Windows\system32\Scrvw4.dll"
I assume you mean srcvw4.dll, not scrvw4.dll...

LoadLibrary("c:\windows\system32\Srcvw4.dll") failed - This application has failed to start because the application configuration is incorrect. Reinstalling the application may fix this problem.

I've tried another computer with XP Pro SP3, incase something was missing from the first one, but exactly the same error.

EDIT: Uninstalled PE, reinstalled last version I was using(5.2.11), and it runs fine on the first machine. I will try it out on the other laptop too, but seems to be something specific to the latest release that is the cause of the problem.

Isn't technology wonderful at times. ;) :D


QUESTION: Does the latest version require files from updates or other Windows applications such as .NET or IE?
 
Last edited:

Technical

Technical Support
Staff member
The problem is Windows is not letting you install the correct version of the file. Note that installing 5.2.11 again will install the wrong version of the file again, it MUST be the version included in 5.3.0 that you use. Ideally you uninstall 5.2.11, make sure there is no version of that file anywhere on your machine, and then install 5.3.0. The installer should automatically register the file, but if it does not you can use regsvr32 to do that.

You should not need anything that is not in the installer, but the new version of this srcvw4.dll file is now compiled with a later version of Microsoft C because of ATL issues in the older versions of Microsoft's C compiler.

We are assuming you are logged in with administrator rights (you do need to be).

Try this procedure:
1) Restart the computer so that the dll has not been used in this session
Unregister the file
regsvr32 /u "c:\Windows\system32\Scrvw4.dll"
Then try to re-register
regsvr32 "c:\Windows\system32\Scrvw4.dll"

If that fails

1) Uninstall the Programming Editor
2) Make sure there are no copies of that srcvw4.dll file anywhere on your machine via a search
3) Reinstall the Programming Editor
 
Last edited:

premelec

Senior Member
Srcvw4.dll

Technical - are you referring to some other file - 'scr...' ? I had a bunch of trouble with this and got it to work on XP HP system but not on old Think Pad Win98 which has no dll's listed under sys32 - I get the runtime error 339.

I had to manually remove the old dll from XP system... before reinstall from BAS805...
 

Technical

Technical Support
Staff member
A 339 issue is normally that the Windows registry is 'confused' over which version of this file should be used. If experiencing that issue our step-by-step guide would be:

[corrected]
1) Uninstall the old version Programming Editor via Control Panel
2) Check that the srcvw4.dll file really has been deleted and is no longer in c:\Windows\system32. If still there manually delete it.
3) Restart the computer.
4) Install the Microsoft files from this link
www.microsoft.com/downloads/details.aspx?familyid=200B2FD9-AE1A-4A14-984D-389C36F85647&displaylang=en
5) Install the Programming Editor v5.3.0 - installation should register the dll automatically

We no longer actively support Windows 95/98 but if you had a 5.2.x version working on that computer then that file must be there somewhere! Installing the Microsoft files from post 7 may also help on these really old machines.



We know this is a pain but is required because of a recently discovered security flaw in Microsofts ATL headers which were used to compile the older version of this file. The new build version does not have this flaw as it is built using a later version of Microsoft's C compiler.
 
Last edited:

premelec

Senior Member
5.3.0 no -> 5.2.11 yes on old Win98 machine

TECHNICAL:
>We no longer actively support Windows 95/98 but if you had a 5.2.x version working on
>that computer then that file must be there somewhere! Installing the Microsoft files from
>post 7 may also help on these really old machines.

For the record after trying many uninstalls deletions of .dlls etc... I couldn't get the 5.3.0 to run on the Think Pad IBM Win98 machine - finally gave up and had an older BAS805.EXE file containing 5.2.11 stashed and ran that and got a working 5.2.11 editor - so I guess that answers "why would you want older versions of the program?" - I can't edit the latest chips but can up to the 20X2 on that machine now... Thanks for your suggestions...

BTW I found the Srcvw4.dll in the system directory but moving it to sys32 directory instead didn't work...
 
Last edited:

Grogster

Senior Member
Process:

- Uninstall PE: [OK]
- Unregister srcvw4.dll - System response: The specified module could not be found.
- Searched whole system for srcvw4.dll, and it does not exist, so this is a truthful message.
- Restart computer: [OK]
- Search for srcvw4.dll again: [OK] (Not found anywhere)
- Reinstall PE: [OK]
- Exact same error:

Run-time error 339

Component 'srcvw4.dll' or one of it's dependencies not correctly registered: a file is missing or invalid.


Srcvw4.dll has been copied into c:\windows\system32 during the installation of PE.
 

Technical

Technical Support
Staff member
Grogster - Have you installed the microsoft files from post #7

The new version is built using VS2005 SP1 (version 8.0.50727.762) so please try installing these files:

Original Microsoft File

http://www.microsoft.com/downloads/details.aspx?familyid=200B2FD9-AE1A-4A14-984D-389C36F85647&displaylang=en

Microsoft security update for file above, use x86 version for 32 bit operating systems, x64 for 64 bit

http://www.microsoft.com/downloads/details.aspx?familyid=766a6af7-ec73-40ff-b072-9112bab119c2&displaylang=en
 
Last edited:

Grogster

Senior Member
Yes I have installed the C++ runtime library 2005.

Still have the same error.

Is it just me, or are others having this problem?
I know of at least one other post on this thread with the same issue, but would be interested to know if anyone else is also having installation problems.

EDIT: I see you have linked to SP1 update - will download and install this and post back. :)
 

Grogster

Senior Member
IT WORKS!!!

Once I installed the SP1 update for the C++ redistributable, it sprung to life with no problems. :)

So, my final proceedure, start-to-finish to install PE 5.3.0 would therefore be:

1) Uninstall any previous version of PE as per the instructions on the RevEd download site
2) Install the SP1 C++ runtime redistributable as linked to in post #13(the 2nd link)
3) Reboot
4) Install the new PE
5) Start coding... ;)

Well, step 5 is not really somethinig I needed to put down...
Step 3 may not be needed either, but I wanted to make sure that anything needed for the C++ SP1 update was loaded before trying to install the PE - perhaps you don't need to do this, and can install one right after the other - Technical will know.

THANK YOU VERY MUCH, Technincal, for your fast and frequent replies.
Now all I have to do, is wait for my 18M2's to arrive, but I am very glad to have this sorted before they arrive, or when they got here, it would have been something of an anticlimax. :D
 
Last edited:

Technical

Technical Support
Staff member
Many thanks for keeping going and helping identify this issue. We test the installer on lots of computers but it is never possible to check every possible Windows configuration, and most users will find they already have these Microsoft files on their machines anyway, hence they will not have the problem to start with.

We will update our posts in this thread for other users and eventually update the installer to correct the issue.
 
Last edited:

smssms

New Member
Run-time error 372

I get "Run-time error 372" associated with my "Failed to load 'SourceView' from srcvw4.dll ..." problem.

Tried the solution in post #15, but still just get the same Run-time error 372 when I try to start PE.

Any ideas?

I cannot see any other mentions of the 372 error....

EDIT - ok, a simpler approach worked in the end, I just deleted the dll. re-installed PE 5.3.2 and it seems to be working now.
 
Last edited:

bbas

New Member
Had the same issues on my XP sp3. The system was supposed to be updated to the las MS updates (running Visual Studio 2010 adn SQL).
The solution was down loading "Microsoft Visual C++ 2005 Service Pack 1 Redistributable Package ATL Security Update" from http://www.microsoft.com/downloads/en/details.aspx?familyid=766a6af7-ec73-40ff-b072-9112bab119c2&displaylang=en.
Installing it.
Without a need to reboot just re-run program editor setup and selected repair.
Works fine without reboots.
All the best.
 

Lenp

New Member
More help with the srcvw4.dll file error

23854
PE5 was previousy installed, then upgraded to PE6. I decided to revert back to PE5 and then this file problem surfaced.
The system was searched for the srcvw4.dll file and it was not in the System32 folder
But.. Regedit found it in the sysWOW64 folder along with many other .dll files
After deleting this file, and doing a repair installation, PE5 installed and runs properly!
This thread put me on the track, and I hope this added information helps another user.

Thanks for this great forum!
Len
 
Top