PNS web server PINGs but HTTP times-out

#1
Hi, I've just unwrapped my new PNS, plugged in and now I'm stuck. I can PING the device OK but the web server isn't responding. Here are the details - can you help?

I'm using a cross-over cable with a fixed IP address, on same sub-net as the PC.
I can PING and get the expected response.
With IE6 pointing at the PNS it hangs around and gives up. With HTTP Get Test I get the message "The current connection has timed out"
I tried the web image upload by uploading one of the default image files, and the FTP gave every indication of working ok. Still nothing on HTTP Get Test. PING still ok.

I next tried using TELNET to access the PNS on port 80. I get a connection, however as soon as I hit the first letter of "HTTP" I got a illegible response of about 55 symbol characters (ok, so the PNS could reasonably be expecting the whole HTTP command in one packet, but why was the response a bunch of strange characters rather than a legible HTTP error response?).

I've tried pointing TELNET at the FTP port and can chat away happily with the FTP server, but after many attempts I can get nothing out of the HTTP server.

Got any ideas as to what I should try next?

Cheers
Simon
 

Technical

Technical Support
Staff member
#2
Have you just ftp'ed the straight image file? You can't do this - you must generate a compressed 'eeprom image' (which can include the graphic) and then upload the eeprom image ie the PNS only works with compressed eeprom images, not straight files.

You MUST also have a file called index.htm in the uploaded eeprom image - so use the PNS website wizard within the programming editor software to compress the eeprom image and then upload it by FTP.

See the manual for more instructions on how to do this.
 
#3
I first tried using the device as supplied, and got the effects described - I was just following the quick start instructions. I next did upload just a bitmap, though using the wizard that compressed it first, but realised this was probably wrong and so then uploaded the whole lot (I selected the folder containing what looks like the default web site files).
If I have 'broken' index.htm doing this, should I expect a 404 or the binary gook I did get?
 

Technical

Technical Support
Staff member
#4
Sounds like an issue with the EEPROM image. Can you check that the 8 pin EEPROM (IC3) is a 24LC512, its under the LCD edge.
 
#5
Thanks for the reply. I've checked the chip and its a 24LC512 and all looks fine there.
I have tried again though and new things happen - mysteriously and all rather unrepeatable I'm afraid. I got readable HTTP responses (404) at one time; I uploaded a trivial web page instead of your full example and a couple of times I managed to GET it using Get Test! - but then I did a ping or something and it just stopped working. The FTP seems faultless whatever I do, but there don't seem to be enough commands implemented for me to use it to test the uploaded web image.
I've tried combinations of reset, power cycling, reload, ping, changing IP addresses all to no avail - nothing really repeatable.
The programming editor access violates from time to time, but it doesn't seem to affect what it does.
If the EEPROM if playing up, could I swap in a PCF8570P RAM that I have to check it?
 

Technical

Technical Support
Staff member
#6
The EEPROM is working fine, it will either work or not. As you have had some http communication at one point, and can ping correctly, and say the Prog Editor violates some times, this all isolates the issue down to some sort of software issue preventing http transfers. The biggest culprit of this is third party anti-virus / firewall software.

Have you tried on a different computer?
 
#7
Good point. I was using a 2K machine of questionable pedigree, so I've brought in a clean XP machine. I put all three machines on the same subnet and ran a program on the 2K box listening on port 80. Plugged 2K and XP together with cross over cable. Telnet from XP to 2K on 80, test program sees typing, proving that the XP firewall is not interfering. Now plug XP to PNS. Check Ping is OK. Check Telnet on 21 is OK. Telnet to 80, get string of symbols in reply to first keypress.
So I'm pretty sure that proves the connection is getting through and data is passing to the PNS. PNS FTP server is fine. PNS HTTP server isnt. All I can do next is find out what the strange characters are that it is returning and see if that reveals anything. Any other ideas?
 
#8
I've put a "plug proxy" in between Telnet and the PNS so I can see what data is being exchanged. Whatever character I type I get the same response immediately. If I power-cycle the PNS the pattern is unchanged.
I can't see any relevance in the characters returned (they're not corrupt ANSI, no obvious pattern matching the expected HTTP reponse). Here are the bytes received in hex (in <>) or ANSI (in ''). Can you see what it means?
<d9> <ec> '<' <f0> <f3> <cf> '=' <f4> <f4> <cf> '>' <f4> '?'
<c4> <1e> <f4> '@' <c4> <1f> <f4> <d9> <ec> '<' <f0> <f3> <cf>
'?' <f4> <f4> <cf> '@' <f4> 'A' <c4> <1e> <f4> 'B' <c4> <1f>
<f4> <d9> <ec> '<' <f0> <f3> <cf> 'A' <f4> <f4> <cf> 'B'
<f4> <04> <01> <08> <0e> 'A' '_'
 

Technical

Technical Support
Staff member
#9
We're as stumped as you at this point. The HTTP inside the PNS firmware basically uses same underlying routines as FTP and PING and so there is no logical reason (firmware wise) why one would work and the other doesn't.

Your welcome to send the PNS back and we will test it for you. We still think it is most likely to be some network issue.
 
#10
I thought I'd take another look at the networking. I stupidly didn't try using my XP machine as the client - I only used it to test the test rig that I'd setup on the 2K machine. So...
It works fine! - using the XP machine. I can use IE to get the web pages from the PNS or telnet to get a 404. From the 2K machine it is still the case of FTP is fine but HTTP isn't at all.
I'm fairly sure all is well at the application level, so that leaves the lower levels and other stuff on the network. An important difference is that the 2K machine is in a domain (but not connected to it) and I suspect it is looking for its friends, so possibly it is broadcasting a lot. I will need to find a packet sniffer to check this out and will report what I find. One other difference is that your FTP server seems happy to accept a command spread over several packets while the HTTP server does not (that is not unusual behaviour), so it might be less happy about other traffic on the network.
Thanks for your help.
 
#11
The problem turns out to be two problems. First is that the Dell Latitude laptop I'm using has a 3Com 3C920 network interface and word on the net is that under some conditions these things drop packets. Using a cross-over cable to the PNS seems to cause the interface to drop packets when there is more than one packet to be received (hence it works on very small web pages but not large ones), whereas using a hub it's all fine.
The second problem is that it seems the PNS doesn't handle retransmissions 100% correctly - the computer asks for the lost packets again and the PNS ignores it because it already thinks the connection has finished. This leads to the browser hanging and eventually timing out.
If you have this sort of problem, my advice is to use a hub instead of a cross-over cable (to be fair Rev-Ed recommend this anyway) and if it still goes wrong make sure there's no reason for packets to be dropped - use a wired network not wireless and get everything else off the network while you check it out.
 
Top