Picaxe Editor Check for new version not working.

Jack Burns

New Member
After doing some tests on Windows 7 with Wireshark Network Analyser, I believe this is what's happening...

PE6 checks for updates at www.picaxe.com/PE6 using HTTP Protocol. The server replies with "HTTP 301 Moved Permanently" and redirects the request to the following secure URL https://picaxe.com/software/picaxe/picaxe-editor-6/

On 25/06/2021 I corrected the links in this post due to misreading Wireshark during my initial analysis (everything else in this post is the same).

PE6 now tries to communicate using Transport Security Layer 1.0 (TLS 1.0) but this fails and the server replies with a "Fatal protocol error" message.
PE6 tries the TLS 1.0 request for a second time and this also fails.

The PE6 error message "unexpected error occured on send" is slightly misleading as Wireshark clearly shows the URL request being sent to the server.

I also tested the URLs on a web browser with different level of TLS enabled within the browser. I found the https pages would only load when TLS 1.2 was enabled. So the problem seems to be that PE6 doesn't have the ability to communicate with the server using the TLS 1.2 Protocol.

I'm not entirely sure what should happen when the "check for updates" feature (presumably) worked in the distant past. Did it just offer a new download within PE6, or did it open a web browser on the PE6 download page???

Last edited:


Senior Member
Thanks @Jack Burns for investigating and reporting back to us. I have not done analysis like you have since I rebuilt my PC after a power surge about a year ago. (In a past life I worked in networking support for a major provider in my part of the world.)

A way forward.

Since PE6.1.0.0 will never be able to report if it has been replaced/upgraded, future readers of this thread can click on the following link to check if later versions are available for download.

Link >> PICAXE-Editor-6 - Software - PICAXE << (Of course, they might change the URL for the software too! ~sigh~ :confused:)

Finally, this morning (Western Australian time), 23-Jun-2021, version is the latest available, so if you have, you are up-to-date. I can't speak for tomorrow, though!!


Senior Member
After doing some tests on Windows 7 with Wireshark Network Analyser, I believe this is what's happening...
Thanks for taking the time to do this - it hadn't occurred to me that the problem might lie 'a level-down' from where I was looking (I just used "Fiddler Classic" - which didn't really show what was going on)

I would have replied sooner, but the forum software decided not to send me any email updates from this thread :(

Jack Burns

New Member
I believe Rev-Ed need to fix this as it looks like PE6 ignores the Windows TLS 1.2 setting and tries to connect using TLS 1.0