No libraries found after installation


Senior Member
Hi guys,
Just installed VSM and when I go to place components I get a message 'No library found'
I wanted it installed on a different Drive so I installed it on my E: drive. I changed the paths to the drive and folder. Now it can't find the libraries.
Any idea where they are? I didn't make a note of where they were in the settings of path. I tried to uninstall then re-install but same thing. My guess is it has held something in the windows registry.

Any help would be appreciated.


Senior Member
Hi Guys,
Fixed it. Had to restore the computer to just before the installation of Picaxe VSM which reset the windows registry. I will have to put up with it being on the C: drive … oh well never mind ;). Libraries are back.


Technical Support
Staff member
Seems you fixed it while I was investigating / typing, so just an FYI which may be of use or not ....

I believe libraries and models should by default end up installed under "C:\Program Files" or "C:\Program Files(x86)" depending on Windows version, as -

...\Revolution Education\PICAXE VSM\LIBRARY
...\Revolution Education\PICAXE VSM\MODELS

If you installed to your E: drive I would have expected all files to have been installed there and everything to have been set up accordingly.

It is not clear what paths you changed after installing, or where you made those changes. If you could let us know exactly what you have done that might help resolve things.