MacAxePad bug: pressing delete adds invisible (ASCII 08, BackSpace) characters, and doesn't delete the preceding characters from the line??


Senior Member
All of a sudden I've been getting a weird bug in MacAxePad, where pressing the delete key adds delete characters instead of actually deleting anything, as well as moving the cursor around 2 spaces forward. This obviously makes axepad unusable for programming, and trying to run a syntax check states "Error: Illegal character: ('^H' (0x08))".

I have tried quitting and reopening AxePad several times, with no improvement. I guess in the meantime I'll have to resort to using blockly, but it seems severely limited in functionality? Does it even have a way to view the serial terminal? I haven't been able to find it if so. If I can't fix this, it will make it much more challenging, or impossible, to finish my final project for my college mechatronics class, which is due next week!

If it helps, I'm running MacAXEpad 1.5.1, on MacOS Mojave, 10.14.6 (I'd love to update to MacOS Catalina, but AxePad and the Command Line Compilers being only 32 Bit is still holding me back).



Technical Support
Staff member
All of a sudden I've been getting a weird bug in MacAxePad, where pressing the delete key adds delete characters instead of actually deleting anything,
That appears to suggest things have been working okay but have now stopped working. I have no idea why that would happen. Backspace is Ctrl-H, ^H, ASCII value 8, so it seems the key is as expected.

It is not clear why AXEpad would have started treating that as anything but the backspace key it should be, has taken to inserting it into the text. There's nothing I can think of which would make it do that, no reason why we would want to. I don't recall any previous reports of AXEpad ever having done that before.

One work round may be to create your code in a text editor then cut and paste into PICAXE Editor 6. It would be worth checking if backspace is working as expected with a text editor.


Senior Member
Thanks for the reply, Hippy.

I've been testing it more, the problem went away for a while, then came back, and now it's behaving normally again (hopefully it doesn't come back again). I forgot to mention that the problem wasn't exclusive to the backspace key, but also others, such as the Escape key. I assume it was similar, inserting the ASCII value that corresponds to escape, but I didn't check to be sure. No other text editors have exhibited the same problem, it seems exclusive to axePad. I ended up installing a linux virtual machine and installing axePad on that, as a (frustrating, but functional) workaround in case the problem returns. The other potential workaround I've identified is to highlight the text you want to delete with the mouse, then type to overwrite it.

I wonder what could be causing the behavior though, that's interesting this seems to be the only known instance of its occurrence, rather than a know issue. Would deleting and reinstalling axePad be likely to help at all?


Senior Member
MacAxePad is working 'normally' for me. I have put normally in inverting commas as the cursor position is often not shown in the correct position relative to the point where text is inserted or deleted though this is a permanent feature for me. It makes trying to delete or insert text into the middle of a line a bit of a game of Russian roulette, but this has been the case for me for almost as long as I have been using MacAxePad.

Have you got the preferences for text set to some unusual combinations?

Screenshot 2019-12-08 at 14.12.39.jpgScreenshot 2019-12-08 at 14.12.56.jpg

I have to add, that once I finally upgrade to Catalina (or a newer version of macOS) I will no longer be able to use PicAxe and my adventures with it will come to a halt. The cross platform usability of PicAxe was the main reason for choosing it at the Further Education centre where I worked. That now has been lost, a shame really as I used PicAxe in all the projects that required logic that I built at the College.
Last edited: