Location of My Documents


To work at different locations on the same project I keep some files in Google Drive.

Since my laptop is running XP and my home PC is on Win7 the exact name of the file locations are different.
Therefor the workspace can't find all files and the #include directive doesn't work either:

On XP the include file is located at:
C:\Users\User\Google Drive\PicaxeProject\Initialization.basinc
on Windows7:
C:\Documents and Settings\User\My documents\Google Drive\PicaxeProject\Initialization.basinc

I could change these lines each time but it doesn't solve the problem that the workspace can´t find the connected files.

Is there a work around for this?


Senior Member
I don't fully qualify the path for the included files (as long as the .basinc files are in the same directory as the .bas files) and they seem to work fine across the few machines I use to edit the code (WinVista (yuk), Win7 and Win8).

So just try just:
#include "Initialization.basinc"
On second thought... I don't use the "Project Workspace" feature of PE6 so maybe that's why it works for me.


Senior Member
Windows 7 should have a 'mirror' of Users called Documents and Settings for compatibility purposes. Use Documents and Settings in Windows 7 and it should work.


A file called test.bas is saved in C:\Users\User\Documents. Its contents:
high B.0
A new file is created in PICAXE Editor 6:
[color=Navy]#include [/color][color=Red]"C:\Documents and Settings\User\Documents\test.bas"[/color]
[color=Blue]do [/color][color=Black]: [/color][color=Blue]loop[/color]
Simulating the code results in B.0 going high.

It doesn't solve the problem of one of your computers not having the Google Drive folder in My Documents but that's not Windows' problem.


I don't fully qualify the path for the included files...
Thanks Hemi345, that is the easy solution I was looking for.

It solves the #Include paths but I am still looking for a way to tell the workspace to look in a different location to find all files.