Issue with AXE027 driver for windows 10 ( does not allocate a virtual COM port ? )


New Member
I would like to use my AXE027 cable on a Windows 10 computer. An it is not successful yet ...
Installation was performed using v2.08.14 USB driver available on Picaxe Website. No issue during installation.
USB Driver seems to be correctly installed as an USB device but unfortunately it seems that Windows does not allocate any virtual COM port ( ? )
Any expert advice would be greatly appreciated ^^
I think windows does not like something but I don't know why ...

Picaxe question.png
Last edited:


New Member
Problem solved today with the following procedure :

- First install FTDI Virtual COM Port driver available on FTDI website ( ) - as a Setup executable
- Plug AXE027 cable
- Select as AXE027 driver the FTDI USB Serial converter ( does not allow the AXE027 cable to work properly at this stage )


- Then change the AXE027 driver to the v2.08.14 USB driver available on Picaxe Website.

Then the ghost on my computer disappear, Windows correctly allocate a virtual COM port for the AXE027 ( COM3 for my computer )


I think AXE027 driver is quite old ( 2011 ) and a windows 10 update should be a good idea !
Not sure this driver is a WHQL certified Driver for Windows 10 ...



New Member
Oh my goodness thank you!

I've been trying to get this to work for two days. My AXE027 kept failing the 'loopback' test. But after installing the FTDI driver it worked! I was then able to install the PICAXE driver over the top and it still works.

This evening I actually got it working in a Windows 7 virtual machine, so I knew it wasn't the cable, then I found your suggestion. Thanks for posting this.


New Member
Gah, it's died again. No joy on Windows 10 or emulated on Windows 7.

Still failing the loopback test - nothing seems to get it going again. It passes the 5V test. I've spent more time trying to get the cable to work than actually programming the PICAXE. Very frustrating.

I used to have an old laptop with a serial port I kept just for this job - maybe it's time to find one again.


I'm not a Windows user, so I have no way of testing this suggestion:

I think you could immunise yourself against any more Windows cockupgrades by changing your cable's PID to the default 6001, and using the default FTDI driver (not the Picaxe driver).


New Member
Okay, after more mucking around I have finally determined the cable has a fault. It just happened to coincide with a windows update. It worked one day and not the next. But if you hold it just right it works.