initiation picaxe pour systeme de jalonnage

PieM

Senior Member
#81
Bonjour,

Elle ne sert à rien si on veut partir de 0 à chaque mise en route.
Mais le programme garde les données en mémoire à la coupure du système. Là, il faut appuyer pour repartir à 0.
Je ne veux pas influencer JTECH, mais à mon avis, faire une RAZ automatique à chaque mise en route serait une erreur...
Elle doit rester une action volontaire donc manuelle. La procédure mise en place dans le programme est à conserver.
Mais le client décide .... :rolleyes:
 

JRTEC

Senior Member
#82
bonsoir

le fait de valider la RAZ par appui long du bouton est une tres bonne chose , si celui doit se produire semoir levé impecable , et le fait que les donnees de surface ou de jalonnage reste reste en memoire apres ne coupure de contact est une bonne chose ( car desfois on cale aussi au milieu du semis )

j ai envie de penche pour le LM393N vous expliquez que le signal sera tres net donc je vais partir la dessus ( j en ai commander d ailleurs )
 

MGU

Senior Member
#83
Bonjour,

Bon, va pour le comparateur. Je fais un schéma avec cette solution.Mais il faudra faire des essais sur site et voir si la norme est respectée.
Cette norme parle d'une tension variable pour l'attelage. Dans tous les cas, le comparateur donnera un tout ou rien (TOR)

Vérifiez le programme dans les détails et dites si les options prises vous conviennent.
Il reste une patte libre, on peut l'utiliser pour régler la temporisation moteur par exemple.

MM
 

PieM

Senior Member
#84
Bonjour,

Une remarque pour JRTECH ;
le fait que les donnees de surface ou de jalonnage reste reste en memoire apres ne coupure de contact est une bonne chose ( car des fois on cale aussi au milieu du semis )
Attention toutefois que la mise à jour des données en mémoire ne se fait qu'en fin de passe ! donc après avoir calé, le comptage reprendra au niveau où il était en début de passe.
Il serait possible de provoquer une mise en mémoire automatique dès que la tension 12V chute, mais c'est peut être un luxe inutile.

Impératif également de conserver la protection du moteur prévue par MGU. La position moteur étant actualisée à chaque passe, il y aura donc une fois sur deux, une commande moteur alors qu'il est déjà en bonne position.
 

MGU

Senior Member
#85
J'ai effectivement ajouté une confirmation de la position à chaque passe (pour voir les voyants s'allumer sur la maquette), je ne sais pas si c'est indispensable.
Un polyswitch est une sécurité, bien calibré, il remplacerait les fins de course. JRTEC semblait penser que le moteur pouvait supporter un blocage de 2s de temps en temps.

Une sauvegarde automatique, intéressant. Comme feriez vous? Il faut penser que count bloque le système jusqu'à 5 s. Doit-on garder un tension suffisante pendant ce temps sur le picaxe?
Si oui, il faudrait séparer les alimentations picaxe / affichage.

Je ne connais pas le nombre d'écritures supporté par les mémoires. Si il n'y avait pas de limitation, une sauvegarde toutes les 5 s...
Avec 100 000 écritures, la durée de vie serait 139h. Après, le picaxe est-il HS ou peut-on changer de mémoire ?

PJ: actualisation schéma
 

Attachments

PieM

Senior Member
#86
J'ai effectivement ajouté une confirmation de la position à chaque passe (pour voir les voyants s'allumer sur la maquette), je ne sais pas si c'est indispensable.
Un polyswitch est une sécurité, bien calibré, il remplacerait les fins de course. JRTEC semblait penser que le moteur pouvait supporter un blocage de 2s de temps en temps.

Une sauvegarde automatique, intéressant. Comme feriez vous? Il faut penser que count bloque le système jusqu'à 5 s. Doit-on garder un tension suffisante pendant ce temps sur le picaxe?
Si oui, il faudrait séparer les alimentations picaxe / affichage.

Je ne connais pas le nombre d'écritures supporté par les mémoires. Si il n'y avait pas de limitation, une sauvegarde toutes les 5 s...
Avec 100 000 écritures, la durée de vie serait 139h. Après, le picaxe est-il HS ou peut-on changer de mémoire ?

PJ: actualisation schéma
Bonjour,

Je pense que la confirmation de la position du moteur est nécessaire car on risquerait une perte d'info en cas d'arrêt .
Le polyswitch est effectivement le plus simple. C'est ce qui est d'ailleurs utilisé sur les lève-vitres des voitures, je crois.

Concernant la sauvegarde automatique, le principe serait d'alimenter le régulateur (de préférence un Low Drop) via une diode, de remplacer la capa de 470µF par une de très forte valeur, et de mesurer en analogique la tension de l'entrée du régulateur via un pont diviseur, sur C.2.

La chute de tension admissible serait donc au mini de 12V-0.7V - 5.5V du régulateur soit 5.8V pendant au mini 5 secondes. d'où I/C = dV/dt = 1.1.
Bon ça fait tout de même 10000 µF pour un courant de 10 mA !
Mais j'ignore la consommation globale du montage . Un 18M2 tout seul consomme environ 1 mA.

Si l'afficheur était sur un autre régulateur pris en amont de la diode ce serait très jouable en effet.
Cela économiserait grandement la mémoire en ne mémorisant qu'en cas d'arrêt de l'alimentation, volontaire ou non.

Sinon, le nombre d'écritures mémoire sur un pic est donné pour 10^6 environ ... Le risque est effectivement de rendre le picaxe inutilisable au bout de 1400 heures environ (statistiquement)...
Au pire, si cette solution était adoptée, c'est de prévoir le changement de picaxe toutes les 1200 heures par exemple, ou d'attendre la panne. Et vu le prix d'un picaxe ...

Une autre solution est de sauvegarder en mémoire externe sauvegardée mais c'est plus compliqué, et il n'y a plus de pins dispo pour communiquer avec !
 

MGU

Senior Member
#87
Bonsoir,

Merci pour ces infos.

Donc, surveillance du 12v et 2200µF (ou même un condensateur de sauvegarde de 1F) sur le picaxe tout seul isolé par une diode.

Qestion pour JRTEC :

Qu'elle serait la surface max à afficher ? Plus ou moins de 19,66 ha?
(La question reste par curiosité, mais le problème est résolu)

MM
 
Last edited:

JRTEC

Senior Member
#88
Bonsoir,

Merci pour ces infos.

Donc, surveillance du 12v et 2200µF (ou même un condensateur de sauvegarde de 1F) sur le picaxe tout seul isolé par une diode.

Qestion pour JRTEC :

Qu'elle serait la surface max à afficher ? Plus ou moins de 19,66 ha?
(La question reste par curiosité, mais le problème est résolu)

MM
bonsoir a l heure actuelle 19.6 ha ce la me va , mais dans l avenir jaimerai plus ( le double environ )

une question a MM :

est ce normale sur le lm393n que l entre semoir soir sur un - et l odometre un + ?
 

JRTEC

Senior Member
#89
lol

et bien toujours de la chance

je viens d essayer avec 2 picaxe 20m2 different , sur platine de test ou sur une platine diveffrente , le programme ne me voit pas le piaxe

vous en pensez quoi , y a t il moyen de reintialiser le picaxe ?
 

PieM

Senior Member
#90
lol

et bien toujours de la chance

je viens d essayer avec 2 picaxe 20m2 different , sur platine de test ou sur une platine diveffrente , le programme ne me voit pas le piaxe

vous en pensez quoi , y a t il moyen de reintialiser le picaxe ?

Pour réinitialiser, il faut mettre le Picaxe hors tension, lancer le chargement programme, et dès que le message "... programming ..." (me souviens plus !) apparait, remettre le picaxe sous tension.
Faire l'essai aussi de mettre un 08M2 à la place (broche à broche OK).
Il y a eu des problèmes sur une série de 20M2 à une époque ...

Quel message s'affiche ?
 

MGU

Senior Member
#91
Bonjour,

Parfois, le sort s'acharne toujours sur les mêmes...

Les premiers 20M2 livrés n'étaient pas reconnus par PE. Mon fournisseur (Gotronic) les a remplacés immédiatement.
Il ne doit plus y en avoir en circulation.

Comme (déjà !) signalé par PieM, une réinitialisation est parfois nécessaire.
Il faut lancer la programmation et alimenter le picaxe ENSUITE, pendant les quelques secondes avant l'arrivée du message d'erreur.
A part ces premiers 20M2, je n'ai jamais eu de problèmes de programmation.

Pour le LM393N:
#66, vous avez mesuré : 0v en haut : 12 v en bas. Soit: 0 en haut ; 1 en bas
Le transistor d'entrée inversait la logique soit : 1 en haut ; 0 en bas . Le programme suit cette logique
Pour garder cette logique et ne pas modifier le programme, le signal semoir est sur l'entrée inverseuse (-).

Pour l'odomètre le sens des entrées n'a pas d'importance. A choisir en fonction de la facilité de câblage.
Sur le LM393, il y a une entrée (-) et une entrée (+) face à face, d'où le choix.

A venir, une nouvelle mouture supprimant la limitation à 19,66 ha.
La mouture est en PJ. La limitation est maintenant l'affichage 99,99 ha .

MM
 

Attachments

Last edited:

MGU

Senior Member
#92
Bonjour,

La version 7 est à jeter.

Deux erreurs : pas de RAZ du comptage tous les 19,50 ha.
Surtout, la sauvegarde est permanente, c'est bien pour l'affichage, c'est moins bien pour les mémoires.

Pour la surface, au bout de 20 heures à 10km/h, l'erreur est quasi nulle.

Voici la version 8 en PJ


MM
 

Attachments

Last edited:

JRTEC

Senior Member
#93
Pour réinitialiser, il faut mettre le Picaxe hors tension, lancer le chargement programme, et dès que le message "... programming ..." (me souviens plus !) apparait, remettre le picaxe sous tension.
Faire l'essai aussi de mettre un 08M2 à la place (broche à broche OK).
Il y a eu des problèmes sur une série de 20M2 à une époque ...

Quel message s'affiche ?
j ai essayer avec un 08m2 : pareil

erreur de brochage de ma part desole j avais pas vu
 

PieM

Senior Member
#94
j ai essayer avec un 08m2 : pareil

erreur de brochage de ma part desole j avais pas vu
:rolleyes: le jour ou vous en aurez fait autant que moi !....


@ MGU

Bravo pour le programme ! Un exemple qui pourrait en inspirer beaucoup ...

Une petite remarque: pourquoi utiliser time pour la durée d'action sur le moteur plutôt qu'une pause qui est configurable avec plus de précision ?

Sur ce sous programme aussi:

Rich (BB code):
'******* Incrémentation et positionnement moteur ***********
'*****chaque passage est confirmé en jalonnage ou non jamonnage ******

increm:   
    on rang goto jal1, jal1, jal0, jal0
   
jal1:    'jalonnage
    time=0:Do :high jalonn:loop while time<2:low jalonn
    goto sortie

jal0:    'ArretJalonnage
    time=0:Do :high pasjalon:loop while time<2:low pasjalon
    goto sortie
   
sortie:
    inc passe        'incrémentation du nombre de passes
    rang=passe//4    'calcul du rang dans le cycle 0 à 3
    passage=rang+1    'numéro de passage de 1 à 4
    gosub affiche    'affichage des modifs
    return
   
'**************************************************************
Mais c'est du détail ...
 
Last edited:

MGU

Senior Member
#95
Bonjour,

@PieM

Merci, vous avez raison, ces lignes datent des premier essais, la fréquence est passée par toutes les valeurs et j'avais choisi time.
Surtout qu'avec la pin libre, on pourrait régler ce temps avec précision.

A ce propos, j'ai essayé time pour sauvegarder les données toutes les minutes, ça ne fonctionne pas. Count doit utiliser le timer et le réinitialiser toutes les 5s.
Alors, il serait possible de sauvegarder lorsque le dernier chiffre passe à 0.

@JRTEC

Une sauvegarde tous les ares ? donc une perte max de 1 are. Utile ou non ? Ou on attend le demi tour.


MM
 

JRTEC

Senior Member
#96
Bonjour,

@PieM

Merci, vous avez raison, ces lignes datent des premier essais, la fréquence est passée par toutes les valeurs et j'avais choisi time.
Surtout qu'avec la pin libre, on pourrait régler ce temps avec précision.

A ce propos, j'ai essayé time pour sauvegarder les données toutes les minutes, ça ne fonctionne pas. Count doit utiliser le timer et le réinitialiser toutes les 5s.
Alors, il serait possible de sauvegarder lorsque le dernier chiffre passe à 0.

@JRTEC

Une sauvegarde tous les ares ? donc une perte max de 1 are. Utile ou non ? Ou on attend le demi tour.


MM
Bonsoir

et encore un grand merci pour votre aide

une sauvegarde tous les are ( soit 100 m² , soit pour 3 m de large , 33 m de parcouru ) ne me semble pas tres utile , je prefere une sauvegarde tous les demi tour
 

MGU

Senior Member
#98
Bonjour,

Voulez vous avoir la possibilité de régler le temps de fonctionnement du moteur par un petit potentiomètre?
Le réglage se ferait en phase "Arret comptages".
Remarque pour la réalisation, " Arret comptages" est un interrupteur (ON-OFF) ou un poussoir à enclenchement. La prise en compte de la position (voyant rouge allumé) varie de 0 à 5s , suivant la fin du comptage.

MM
 

MGU

Senior Member
#99
Bonjour,

Une petite mise à jour pour le WE
Avec un potentiomètre en plus pour régler la temporisation entre 0,5 et 3,5 s
Un toilettage du programme avec mode d'emploi.
Le positionnement du jalonnage est ajouté sur l'afficheur : O pour OUI; N pour NON
Le tout en PJ
 

Attachments

Last edited:

JRTEC

Senior Member
lm393 montage picaxe.JPG Bonjour

et encore merci pour votre attention

cette nuit j ai fini mon boitier
et du coup je le teste sur le tracteur

mais j ai un probleme avec le lm393 n

J ai mis en piece une partie simplifie du montage afin de pouvoir m expliquer :

Donc pour commencer le LED verte est toujours allumée sauf si j applique un + 5V en C4 donc le picaxe vois bien cet commande

le LM 393N lui me donne du fils a retordre : que l entre 2 soit a 12 v ou a 0 V la sortie 1 est toujours a 0 v l entree 3 elle est constante a 3.42 v

qu en pensez vous ?
 

JRTEC

Senior Member
Bonjour,

Une petite mise à jour pour le WE
Avec un potentiomètre en plus pour régler la temporisation entre 0,5 et 3,5 s
Un toilettage du programme avec mode d'emploi.
Le positionnement du jalonnage est ajouté sur l'afficheur : O pour OUI; N pour NON
Le tout en PJ
merci pour la modif

vous mettez un potentiometre de combien 10 Kohms ?
 

MGU

Senior Member
Bonjour,

Il manque deux résistances sur votre schéma.
Les sorties du LM393 sont des collecteurs ouverts. Comme pour des transistors standards, il faut relier les sorties par résistances "de tirage" au + 5v pour que cela fonctionne.
(voir le schéma fourni) , j'ai mis des 10K (des 4,7k conviendraient) mais je n'ai pas testé cette partie (pas de LM393). Ça devrait fonctionner.

J'espère que vous n'avez pas relié la sortie des LM393 directement au +5v , parce que sans limitation de courant dans le transistor de sortie du lm393 ...Aie! Il y a parfois des limiteurs de courant dans les CI, le lm393, je sais pas.

Pour le potentiomètre, la valeur n'a pas d'importance disons entre 1k et 10k.

MM
 
Last edited:

JRTEC

Senior Member
Merci encore une fois vous avez raison

Bonsi cela vous dis , j ai essaye avec le version 9 du programme ( du coup j en avais essaye aucune avant)

je me suis apercu de plusieurs choses :

a la coupure du contact perte de la surface ( j avais 0.01 ha , et quand j ai remis j ai 0.00)
il semblerai que l electronique du tracteur fait un check up , du coup le signal de relevage bas arrive 2 a 3 secondes apres la remises du contact ce qui entraine l incrementation du passage
d ailleurs vis a vis de ce probleme et pour un ordre pratique , je me demande que plutot qu un plus 1 manuel ( que je peux faire avec le relevage ) je ne prefererai pas un moins manuel

et encore merci c est vraiment sympa de votre part de m aider
 

PieM

Senior Member
a la coupure du contact perte de la surface ( j avais 0.01 ha , et quand j ai remis j ai 0.00)
Bonsoir,

n'oubliez pas que la mémorisation des données se fait lors du relevage de l'attelage ...
petit rappel aussi : la mémoire est remise à 0 lors d'un chargement programme.

Sinon, pour le reste, il est possible effectivement qu'il y ait un temps de latence due à l'électronique des accessoires. Une tempo à la mise sous tension du picaxe devrait résoudre le problème. Je ne sais pas ce qu'en pense MGU ?
 

JRTEC

Senior Member
Bonsoir,

n'oubliez pas que la mémorisation des données se fait lors du relevage de l'attelage ...
ah ok , alors d un arret il ne faut reposer l outil au sol

mais pourtant j avais relever avant , puis lorsque j ai garer le tracteur la j ai baiser le relevage , arret du moteur
et la remise du contact

donc meme si la memo a eu lieur avant ,elle est perdue en cas de calage

pour info j ai pas encore la diode 1N4007 qui est indique securite lors d une coupure ,
 

MGU

Senior Member
Il est normal de perdre la surface si il n'y a pas eu de relevage ni de passage en mode "arrêt" voyant rouge allumé.

A la première mise en route du système, (si il n'y a jamais eu de mémorisation), l'affichage est JALONNAGE 0/4, il faut faire un cycle de +1 pour initialiser le programme (pour l'instant). Ça permet de faire un essai de fonctionnement de positionnement du jalonnage, si il y a une led témoin sur les relais, il faut attendre l'extinction.

Juste avant de commencer le travail, il faut positionner manuellement le compteur de passe soit à 1 si le semoir est bas ou 4 si il est haut (passera à 1 à la descente). Après, les passages doivent s'enchainer automatiquement

Si le système est mis sous tension directement, sans interrupteur indépendant, on peut temporiser la mise en service avec un délai de quelques secondes, le temps que l&#8217;électronique tracteur se stabilise.

Le +1 manuel utilise le même sous programme que le relevage tracteur. On peut sans doute ajouter un sous programme "-1" . Mais en appuyant 3 fois sur +1, ça fera la même chose mais un -1, pourquoi pas si c'est plus pratique...

Le comptage de la surface est-il exact? Faire un essai sur une distance connue plus longue.

Il y a un petit défaut d'initialisation du OUI / NON sur l'affichage, je grouperai les modifs.
 
Last edited:

PieM

Senior Member
ah ok , alors d un arret il ne faut reposer l outil au sol

donc meme si la memo a eu lieur avant ,elle est perdue en cas de calage

pour info j ai pas encore la diode 1N4007 qui est indique securite lors d une coupure ,
Non, la mémorisation ne peut être perdue que si on fait une remise à zéro manuelle.
Je ne vois pas à priori ou peut être le problème ... on va laisser MGU cogiter !

(MGU :Concernant la diode en // du régulateur, je n'ai pas compris son utilité )
 

JRTEC

Senior Member
pour la surfaace je vais voir demain grandeur nature

je n ai pas besoin du jalonnage mais ccela me donnera une idee suivants les parcelles
 

MGU

Senior Member
Oui, la diode sur le régulateur, c'est du zèle.
Il y a au moins deux façons de détruire ces régulateurs:

- dépasser la limitation de tension d'entrée
- provoquer une inversion de polarité entre l'entrée et la sortie. Ex, faites l'expérience comme moi avec un beau condensateur à la sortie d'un régulateur 7812, vous faites un court circuit sur l'entrée. Le régulateur est mort. La diode protège en limitant l'inversion à 0,7 v (non destructeur).

En fait, je mettrais plutôt cette diode avant le régulateur, dans le sens direct, il y a protection en cas d&#8217;inversion de branchement et en cas de CC à l'entrée, la première capacité reste chargée et la sortie chutera avant l'entrée.

Je propose à JRTEC de faire un essai complet avec initialisation, demi tour, comptages, mesure de surface.. et de faire un bilan des problèmes en essai grandeur nature
 

JRTEC

Senior Member
Je propose à JRTEC de faire un essai complet avec initialisation, demi tour, comptages, mesure de surface.. et de faire un bilan des problèmes en essai grandeur nature
Demain je ne me sert pas du jalonnage

par contre je n ai pas mis e potentiommetre donc je presume que ce sera la tempo maxi ( 3.5 secondes si je ne dis pas de betisse )
 

MGU

Senior Member
Si la pin n'est pas connectée, je ne sais pas ce que va mesurer l'ADC. Si c'est 0v, tempo = 0,5 s . Pour 2 s, il faut C.2 à 2,5v donc un pont de deux résistances identiques.
De toutes façons, il est préférable de fixer le potentiel. de C.2. A 0v pour 0,5 s si pas besoin de jalonnage.
 

JRTEC

Senior Member
Si la pin n'est pas connectée, je ne sais pas ce que va mesurer l'ADC. Si c'est 0v, tempo = 0,5 s . Pour 2 s, il faut C.2 à 2,5v donc un pont de deux résistances identiques.
De toutes façons, il est préférable de fixer le potentiel. de C.2. A 0v pour 0,5 s si pas besoin de jalonnage.
ok je viens de mettre pour une question de place 2 resistances de 22 k
 

PieM

Senior Member
- provoquer une inversion de polarité entre l'entrée et la sortie. Ex, faites l'expérience comme moi avec un beau condensateur à la sortie d'un régulateur 7812, vous faites un court circuit sur l'entrée. Le régulateur est mort.
Bonjour,
Merci du tuyau: je ne connaissais pas...
 

MGU

Senior Member
Bonjour,

Et sur un tracteur ou une voiture , couper le contact ne fait pas que supprimer le 12v mais tous les accessoires en service sont équivalents à un court circuit. Donc, danger.

MM
 

JRTEC

Senior Member
Bonjour

alors bilan bilan ( tres positif ) de mon essai en nature :

* surface : par rapport aux declaration sattelite je tombe pile poil sir un essai de 4.01 ha ( surface semée hier 8.5 ha ) a une vitesse entre 5 et 7.5 km/h , odometre branche sur la vitesse reel c est a dire le radar : juste une remarque il semblerai qe la surface ne soit pas memorise a la descente , mais juste apres en avancant , non je dis cela car lors dun remplissage : donc pour info levé , puis parcourir une distance d environ 30 m lors de ce cas ,baiser puis coupure du contact la a ce que j ai vu j ai pardu une partie ( de 1.84 ha je suis redescendu a 1.79 lors du redemarrage du moteur )

* consernant le comptgae de jalonnage : donc je confrme que l ors du la mise du contact contage d un passage de plus , de meme que si apres lors du demarrage il y a une forte chute de tension meme constat : incrementation du jalonnage , une tenpo de 5 seconde en phase demarrage comme vous parliez serait un plus

consernant le plus 1 manu , impeccable , a ce que j ai vu il faut le tenir pressé 1 seconde

je dois avoir un probleme hardware : mon blocage ne marche pas , et je n ai pas tester la RAZ

bonne journée
 

MGU

Senior Member
Bonjour,

Bon, pour un premier essai, c'est pas trop mal.

Le blocage ne fonctionne pas: Vous utilisez probablement un poussoir fugitif, sur le schéma, il y a un interrupteur à 2 positions stables ON - OFF (ou un poussoir à enclenchement).
Je peux programmer un poussoir fugitif en va et vient, le voyant rouge mémorisant la position. Mais le ON - OFF est préférable parce qu'il faut toujours attendre la sortie du comptage (de 0 à 5 s)
Confirmez moi ce que vous utilisez actuellement et ce que vous préférez.

Normalement, la mémorisation se fait une seule fois lorsque l’attelage est en position haute ou une seule fois en position blocage.
La prise en compte n'a lieu que lorsque le voyant vert est éteint ou le voyant rouge allumé (indique la sortie de la fonction comptage surface)

Pour les problèmes vus au démarrage: 5 secondes de temporisations ok. Ajoutez une diode IN4007 (sens passant bien sûr) avant le premier 470µF pour éviter les chutes de tension trop brutales (voir post précédent) .

Le poussoir +1: Un fraction de seconde devrait suffire mais surtout, il faut attendre la fin temporisation moteur (ex 2 s) pour pouvoir recommencer.


Version 10 à suivre, en fonction de votre réponse.

Je pense ouvrir une page sur le blog que vous connaissez, décrivant le système. J'ai fait un typon (carte de 8cm x 9cm contenant tout, relais compris).
Si vous pouviez me donner quelques renseignements sur le matériel ex: type tracteur, moteur utilisé pour le positionnement ( et si possible quelques photos)

Bonne journée

MM
 
Last edited:

JRTEC

Senior Member
bouton.JPG
Bonjour,

Bon, pour un premier essai, c'est pas trop mal.

Le blocage ne fonctionne pas: Vous utilisez probablement un poussoir fugitif, sur le schéma, il y a un interrupteur à 2 positions stables ON - OFF (ou un poussoir à enclenchement).
Je peux programmer un poussoir fugitif en va et vient, le voyant rouge mémorisant la position. Mais le ON - OFF est préférable parce qu'il faut toujours attendre la sortie du comptage (de 0 à 5 s)
Confirmez moi ce que vous utilisez actuellement et ce que vous préférez.

Normalement, la mémorisation se fait une seule fois lorsque l’attelage est en position haute ou une seule fois en position blocage.
La prise en compte n'a lieu que lorsque le voyant vert est éteint ou le voyant rouge allumé (indique la sortie de la fonction comptage surface)

Pour les problèmes vus au démarrage: 5 secondes de temporisations ok. Ajoutez une diode IN4007 (sens passant bien sûr) avant le premier 470µF pour éviter les chutes de tension trop brutales (voir post précédent) .

Le poussoir +1: Un fraction de seconde devrait suffire mais surtout, il faut attendre la fin temporisation moteur (ex 2 s) pour pouvoir recommencer.


Version 10 à suivre, en fonction de votre réponse.

Je pense ouvrir une page sur le blog que vous connaissez, décrivant le système. J'ai fait un typon (carte de 8cm x 9cm contenant tout, relais compris).
Si vous pouviez me donner quelques renseignements sur le matériel ex: type tracteur, moteur utilisé pour le positionnement ( et si possible quelques photos)

Bonne journée

MM
Bonjour

c est clair que cela marche bien

consernant le bouton j utilise bien un bouton a bascule ( j ai une photo en piece jointe )
il faut que je verifie mon montage

pour les photos et le materiel pas de prrobleme je vous envoye cela sur votre boite mail chez free

je vais aussi rajouter la diode

merci
 

MGU

Senior Member
Bonjour,

En PJ, une version 10 et le schéma final.

Peu de modifs: une temporisation de 5 s au démarrage. passage jalonné marqué par "|" ou rien, plus visuel que "O" et "N".

Si le voyant rouge ne s'allume pas dans les 5 s suivant la mise sur "arrêt", il y a effectivement un problème quelque part.

Pour l’arrêt, vous devriez avoir:
La séquence : semoir bas / arrêt on / ...../ semoir haut / arrêt off / semoir bas => +1
La séquence : semoir bas / arrêt on / ...../ semoir bas / arrêt off => pas de +1
Mais:
La séquence : semoir haut / arrêt on / ....../ arrêt off / semoir bas => pas de +1


Merci pour les photos, beau petit tracteur. Prochainement une description complète de ce projet sur le blog.
A ce propos, y a t il une connectique particulière sur ces tracteurs, comment est raccordé le vôtre ?
Quel boitier utilisez vous ? Comment est il fixé? Doit il être étanche?

MM
 

Attachments

Last edited:

JRTEC

Senior Member
Bonsoir

consernant la connectique , elle repondont a la norme iso 11786

j ai toujours comme prise la meme que la mienne est ceci sur plusieur marque de tracteur : connecteur CA 6 LS / ref 934 126-100 / ref farnell 3611899

j utilise un boitier d un ancien boitier electronique embarque dans une cabine de tracteur corp en alu ( ceci evite le parasitisme : Cibi , radio , etc ..)

il est fixe de maniere demontage sur un support personnel , il n y a pas de norme dans ce cas

Comme il est utilise en cabine , come pour recolte ces signaux il fait de l electronique , je ne connais pas de tracteur equipe d une prise ISO 11786 qui sont sans cabine , donc pour moi pas utile d etre etanche a l eau , par contre un minimun etanche a la poussiere
 
Top