Getting AXE027 working


New Member
It is many, many years since I have used a PICAXE, but I now have a simple application for using one. I found some -08s in the junk box, which I had forgotten about, but they will be ideal for my application. I decided to start by programming one with the simple Flashing LED program to make sure things are working. I have an AXE027. When I tried to load the program I received the "Error: Hardware not found on COM6" message. I am using Windows 10. I have been reading several threads, trying to get ideas.

Here is what I have found so far: I have done the Hardware check on the AXE027, and it passes. Under Settings/Devices, I can see "AXE027 PICAXE USB". Under Device Manager, Ports (COM & LTP), I see "AXE027 PICAXE USB (COM6)". When I right click Properties, I see "This device is working properly". Under Driver, I see Version Under Events, Information, I see "Device FTDIBUS\VID_0403+PID_BD90+5&212ac8fc&0&1\0000 requires further installation." I have downloaded the AXE027_USB_Driver zip file and have unzipped it in a clean folder- with the amd64 and i386 files I have seen mentioned.

I am far, far from the most computer literate or computer capable person around, and some of the comments/suggestions I have read leave me cold- especially about some two step installation processes and deleting drivers.

What should I do, and where should I go from here.

Thank you in advance


Senior Member
... I have done the Hardware check on the AXE027, and it passes. ...
Do you mean the loopback test, with the paperclip or similar ?.


If this test has passed, then all is fine with your computer and cable. The problem is at the PICAXE chip end.

Please post some photos.




Technical Support
Staff member
Sounds like the 08M's might just need a Hard Reset download to get them to work. They possibly have some old code in them preventing download being seen.


New Member
Hi Buzby, Hippy,


Thank you for both taking the time to reply. Buzby, your comment that the cable passed the hardware test was very reassuring. This forced me to go looking elsewhere, rather than assuming that the problem was with the computer. I tried a second -08 chip I had- but no difference. I had previously waded through the data for the 12F629, which said the Vcc limits are 2v to 5.5V for the 12F629. I was applying 4.38volts- which was within their spec limit. Then, when searching again through the PICAXE manual, looking to see if there was an alternative way to do a Hard Reset, I saw a note suggesting that the minimium Vcc for reliable operation should be 4.5volts. To be sure, I changed the power supply arrangement to give 5.1volts- but this made no difference. I cannot remember the history of the protoboard I am using, but I started checking it again, and again. Everything seemed OK- until I checked the connections from the stereo 3.5mm socket for the AXE027 connections to the board. When I checked this, I found that I had swapped over the tip and sleeve connections. I had obviously assumed that the sleeve was the ground for the AXE027. This fixed the problem- and everything is working OK. As I said, the history of this (commercial) board, and the way it was connected up, is lost in time. But obviously, I must not have used it successfully.

(I wanted to give a complete reply and explanation, in the hope that it might help someone else in future.)

So, thank I both of you once again for taking the time to reply, and pointing me in the right directions. Very, very much appreciated.