Download to Picaxe via PNS


New Member
Hi, Iam a bit new to this but I have a PNS on my home network and I have set it up and it works fine. I have set the router to forward port 80 and I can get remote access without any problems with the net demo board connected.
The problem came when I have tried to download a very simple program to a 28X chip in the axe022 project board. The program just switches an LED on and off on output pin 7.
The download to picaxe always returns a failed message and I can no longer view the web pages and I have to download the webpages again in order to view them. The 3 jumpers are all in the RH position enabling download and power to the board from the PNS.
The netdomo board works fine.
Any ideas?
Iam downloading the picaxe program via the network, FTP, then "programme picaxe". The FTP transfer is fine and returns a sucessful message.
Last edited:


New Member
since my last post I have done a bit more experimentation. The problem appears to be the PNS. Having sent a picaxe program via FTP, the PNS appears to lock, and wont allow web pages to be displayed and any attempt to continue and program the picaxe chip always returns a failure. The only way to then get the PNS to serve the web pages again is to reload the web pages again by FTP, then the PNS works again as it should.
Have I missed something obvious?
I've not tried remotely programming a PNS via FTP, but I'd ask "where does it put the uploaded program before programming it?" The PNS doesn't have bags of spare memory, so maybe the webpage store gets overwritten with the uploaded program. The docs don't say either way, but maybe you're supposed to have to reload the web pages after programming.
You did say you get an error message - from the Program command I assume - so maybe there's a different problem too.
The docs do note you have to do the right thing with Output 0 else you get the whole system locked up - is that relevant? I guess your simple program leaves it alone though you do talk about it locking up.
Best of luck!


New Member
I hope your problem has been resolved by now premier8. For the record the download you describe first requires the additional Access password to be set. See page 10 of the PICAXE NET Server manual. This can be set from the Programming Editor>>Wizards >>NET001 >> CGI GET Test. From the Commands drop down menu select '10 Enter Password' and in the adjacent box add the password (the default is access12). My server IP address (e.g and the Filename (index.htm) came up as the default.