AXE027 Cable driver with windows 7

#1
Hello
I am currently trying to install the drivers for the AXE027 cable on windows 7 but it wont see the drivers ,i have located the file on the desktop etc and tried some other ways to get the operating system to see it .Has anybody else had this problem? or now a method to work round it ,the cable etc and circuit work fine on xp and program etc so theres nothing wrong with the cable etc.

Cheers
gringo8217
 

hippy

Technical Support
Staff member
#2
Welcome to the PICAXE forum and sorry to hear you are having problems installing the AXE027 drivers.

The installation process should be as described in -

http://www.picaxe.com/docs/axe027.pdf

Two important things to ensure for manual installation are -

1) That the files are extracted from the downloaded .zip to a separate directory on disk. If not the files may appear to be seen by Windows Explorer but not by Device Manager.

2) When pointing Device Manager to the extracted directory, the top level directory must be selected; the one containing the 'amd64' and 'i386' sub-directories.

Also note that the installation is a two-step process. If the second step is not completed then there will be issues in accessing the installed AXE027 cable.
 
#3
I have a similar problem... I'm using Windows 7 Home. I have tried many times above mentioned procedure, but still received message:

"Windows cannot verify the digital signature for the drivers required for this device. A recent hardware or software change might have installed a file that is signed incorrectly or damaged, or that might be malicious software from an unknown source. (Code 52)".

How to resolve this problem?
 

hippy

Technical Support
Staff member
#4
The appearance of that message is described on page 9 of the installation guide along with the resolution which is is to click on "Install this driver anyway".

The generic FTDI drivers being installed have passed Windows logo testing but, due to legal reasons, when distributed by a third party like ourselves, they cannot currently be marked as having passed logo testing. Windows flags this as you are seeing but should allow installation to continue anyway.

If there is no "continue anyway" option presented it could be that the PC has been configured to reject all unsigned drivers without allowing the option to continue.
 
Top