AXE027 Cable - Code 39 Error

PSc

New member
I am trying to install an AXE027 cable onto a windows 10 PC with no joy. I have installed the cable and drivers on multiple machines over a number of years so I know that it isn't something I am doing wrong in terms of installing the drivers. I've chatted to tech support and they have seen this error also, but currently don't have a fix, so I am putting it out into the hive mind to see if others have a solution.

Machine details
Dell Latitude 7410 (touch screen laptop)
Windows 10 Education
Windows version: 1909
OS Build: 18363.1139

I have tried uninstalling the drivers completely, un-installing and re-installing the PE6 software and using different ports (both in the docking station I use and directly in the laptop itself) - they all give the same error. I install the pre-installer and that works. I plug in the AXE027 cable and it finds it. I then try to update the driver to the one downloaded either from the picaxe site or as part of PE6 and it gives me a code 39 error.

I have tried uninstalling the USB drivers completely. I've also read about deleting registry keys, but haven't tried that.

Picaxe have said they have heard of this happening with Surface Pros, but not a Latitude.

The interesting element is that our school did have the 2004 version of windows 10 on the laptops, but it was causing all kinds of problems with using the touch screen and interactive boards. The solution was to change to the 1909 build which was stable. When my laptop was on the 2004 build, the AXE027 installed. Now on the 1909 build it doesn't. I know the simple solution is "just go back to the 2004 build", but that was spectacularly unstable.

I have tested the cable on another machine (ironically a surface pro) and it works fine so the cable itself is not damaged.

Any suggestions...?
 

kfjl

Member
I don't know anything about Windows, but maybe changing the FTDI chip's PID (using FTPROG) to the standard 6001 might do the trick.
It works with Linux.
 
Top