Another Case Of Verification Error On Download


Senior Member

... purposely exceeding the voltage ratings on the pin. ....
Other ideas I've considered are resistor divider, zener clamp, and maybe using an external Schottky
Before USB to Serial adapters, the PICaxe was designed to be programmed directly from RS232 (serial) levels (e.g. from a PC COM1 port) which can be as high as +/- 15 volts. The 22k resistor limits the current and the on-chip "protection" diodes limit the voltage swing. Microchip rate these diodes to 20 mA so it should work perfectly safely, but you can add an external Schottky diode if you feel more comfortable*.

However, where a Schottky might be necessary is if there is a large negative voltage. The negative protection diodes are a "substrate diode" and current flowing in the substrate can upset parts of the microcontroller, particularly the ADCs For this reason Rev Ed used to show an "Enhanced Serial Download Circuit" in Manual 1, but have now deemed this to be unnecessary since most USB-serial adapters (including the CH340 "blue" adapters) deliver only 0 - 5 volt levels.

*But there is one "gotcha" if you rely on a clamping diode (either internally or an external Schottky) which is "Phantom Powering". A PICaxe needs only around 600uA to run, so 22k is about as low as you can go before there is a risk that the PICaxe will continue to run from a "clamped" 15 volt external "logic" input, via the protection diode, even when the PICaxe's power supply is disconnected. Not usually a problem but it might cause the PICaxe not to Reset when you think it has/should. As you indicated, zener diodes below 5 volts have a poor "knee" (in their V/I curve) so the simplest solution may be to ensure that there is sufficient current drain (perhaps just a resistor) from the supply rail to ground.

Cheers, Alan.

Paul Hoshovsky

New Member
If I may intrude.

I am seeing the error "hardware not found" occurring more frequently. Last week, I was able to program the 18M2 on its project board CHI030 but only after I got three errors "hardware not found". today I tried to download the code to the 18m2 and Yep, got the error again. So I ran the configure tests inside Picaxe Editor and discovered that the 20V signal was not present. I can only assume that it was present last week. Otherwise the download would not have worked. I checked the supply voltage - it was 4.95 V on the project board. I really don't want to buy another cable......

caio Paul


Senior Member
@Paul. Which download cable are you using? It is unusual to have (or expect) voltages as high as 20v from serial leads coming from a computer - even from a true RS232 serial port. What voltages do you read (high and low) on the output of your cable?