20m2 stops working when i run a plasma cutter

newplumber

Senior Member
#1
Hello to anyone
I wanted to type this in the form box but don't know how.. still new to this site . I made a cnc plasma table from scratch and I use one picaxe 20m2 chip which works awesome and my table works awesome if I just put a pencil and paper it will draw anything I program it to do.. so I thought sweet now I can just add the plasma torch and use a pin with trans to a relay to turn the plasma on and off anywhere I want it to. But before I added the relay I decided to use the plasma switch manually while the stepping motors were running a simple code I programmed. As soon as I hit the switch to start cutting the chip 20m2 just dies and I tested my power with a meter and it doesn't flinch on 5 volt. If I have the plasma cutter on and don't plasma cut (with just the power an fan running) ..the stepping motors and chip run perfect as soon as I hit the switch to start cutting with air blowing thru tip.. the chip dies and of course same with the stepping motors and restarts when I let go of the cutting switch. I am using a pc power supply rated 25 amps at 5 volts ...120v ac and my plasma cutter is using 240 volt ac I tried using 8 more bigger caps on the board ... I installed a ground rod right next to my breaker box. I changed the plasma cutter to a different plasma cutter which runs the same power 240 v ac I changed pc power supplys and still when I go to plasma cut the chip 20m2 dies so something from my 240 volt ac and the 120 ac freaks out the 5 volt dc power supply.. I'm just wondering if anyone had this problem before. I have my ser IN pin to ground with 20,000 ohm resistor plus a capacitor right on pin 1 and 20 if your reading this sorry about typing so long but I guess I will try something else I know the chip is resetting because it starts the code over when I let go off the plasma switch. I don't even have no ground or plasma tip close to the table and it still kills the chip if any has any ideas much thanks ahead of time thanks again
 
Top