Search results

  1. K

    PE6 = no comm port found

    Hi folks, I recently decided to upgrade to PE6 editor on a modern laptop (Lenovo, Windows 10). I downloaded/installed PE 6.0.8.11 and also AXE027 drivers. I plugged in the AXE027 cable and confirmed that it was recognised by Device Manager. Then I opened the Editor and noticed that it said "No...
  2. K

    serin variables

    Hi folks, If I send 16 bytes as one serial message, there is only a max. of 14 GP variables available to receive same, using Serin. Is there a way around this, apart from splitting the data into separate sends? Is it possible to put the Serin data directly in other variables? Kenmac
  3. K

    i2c LCD control

    Hi folks, I have a project that uses a standard parallel LCD, but I need to fee up some Picaxe pins for other things. So, I have obtained a 16x2 LCD that uses i2c for control - apparently it is meant for use with Arduino's. Unfortunately I haven't been able to find any info on how to control it...
  4. K

    AXE027 failure

    Hi Folks, This is just to advise that my AXE027 cable has failed. It was during a run of programming on a 08M2. Everything was going OK when it suddenly stopped. Previous to this, I haven't had any problem with it - always worked OK. I checked the serial input line using the Test button under...
  5. K

    Program problem on Picaxe20M2

    Hi folks, I haven't been on this forum for awhile. I have been trying to use a 20M2 to drive a 7 segment display. To test it out I used the following program: 'test_7segment_2.bas 'This program tests the control of a 7 segment display using a Picaxe20M2 ' 'Connections: 'c.0 ..... 10K to...
  6. K

    serin problem on 20M2

    Hi folks, I have been dabbling in programming of the new 20M2 and have run into a problem with the SERIN function. Sending a byte from a 40X2 chip is not read correctly by the 20M2. The data is sent as N2400 with no qualifiers. If the data byte is $01, the 20M2 interprets it as $F0. (read via...
  7. K

    Picaxe28X1 - PortC masking

    Hi folks, I haven't been here for a while. I'm starting a new project using a 28X1 chip, a type I haven't used before. I've configured PortC as all outputs [ dirsc = %11111111 ] The first four bits will be varied together, while maintaining the current status of the other bits. To do this, I was...
  8. K

    usb driver install failed

    Hi folks, I recently decided to change to usb for the purpose of programmimg the picaxes. I have been completely unsuccessful in installing the appropriate driver software. First I tried on a laptop with Win ME - it wouldn't "see" the driver even when actually pointed to! The usb device was...
  9. K

    Picaxe08's stopped programming

    Hi, I have two 08's that have been working normally, accepting programming etc. They both have now ceased accepting the "in circuit" programming signal. I did the serial port check and found that the pin2 voltage was only varying from -0.55 to 1.57V. The voltage from the laptop is -5.33 to...
  10. K

    Beware the forgotten Debug

    Hi folks, I've just experienced an event with a 08, which had me puzzled for a while. I'd finished programming it to control a couple of transistor/relay and LED outputs, one of which was on Pin0. Having disconnected the programming cable, I was in the process of final testing when I noticed...
  11. K

    Attention Technical: 40X1 possible bug

    Hi, I've been programming a 40X1 for the first time and ran into a problem with the setting of the output pins. Example: pins = 112 (%01110000) results in the state of the pins actually being 240 (%11110000) Actually, any value not using the msb results in the msb being set. pins = 240 results...
  12. K

    LCD Enable - problem with using portC output

    I have covered this in a previous thread (archived). Basically, using a 40X portC pin to drive this particular LCD that I'm using doesn't work. The cause is the minimum pulse out is approx. 300uS using high/low code. Initially I was able to work around this by using a standard Output pin...
  13. K

    28X PortC pins 2,3 problem

    Hi folks, I was working on programming I2C on a 28X when I had a problem. Testing the SCL (pin c3) showed that it wasn't changing. I then ran a quick programmed basic output check, monitoring the port with LED's on each pin. This revealed that pins c2 and c3 were not responding to "high...
  14. K

    40X Simulation

    With the current Simulation setup (5.08)for a 40X we can only control as per the 28X - the graphic shows a 28X chip and therefore some 40X pins aren't simulated. Is it proposed to fix this with the new 40X1,X2 chips? kenmac
  15. K

    28X programming problem

    I have been programming/testing a 28X "in circuit", debugging sections of a main program. Everything was going according to plan, when suddenly the 28X ceased responding to programming commands. The last section of program under test is still working as required, but I can't get it to...
  16. K

    40X Standard Inputs simulation

    The Program Editor (V5.08)sees the 40X as the same as the 28X. This is OK for coding, but unfortunately it ignores the extra 8 standard inputs when using the Simulator. Is it intended to provide a full simulation of the 40X in future? kenmac
  17. K

    Picaxe40X - portC Output problem

    I've just moved up to a 40X, using it to drive a parallel LCD, among other things. Initially I set it up to use the first 4 Output pins for the LCD data, and two portC output pins for the RS and EN lines. The EN pulse is supposed to be short and so it was programmed as "high portC 2&quot...
  18. K

    installing bas805.exe - password box

    Hi, Have downloaded latest version and received password in Email. Tried to install but can't get past the password box - the OK button is disabled (greyed out)! ?? regards kenmac
Top